Empty input

WordPress 4.8.2 fixed 9 vulnerabilities - but still refuses to fix CVE-2017-8295

WordPress 4.8.2 comes with fixes for 9 vulnerabilities, but refuses to fix CVE-2017-8295

On 19 Sep, 2017, WordPress 4.8.2 was released to the public. Nine high security issues are fixed but Core Team still refuses to fix CVE-2017-8295 - Host Header Attack Vulnerability. 36 millions of websites affected.

From the WordPress 4.8.2 release post: WordPress versions 4.8.1 and earlier are affected by nine security issues:

  1. $wpdb->prepare() can create unexpected and unsafe queries leading to potential SQL injection (SQLi). WordPress core is not directly vulnerable to this issue, but we’ve added hardening to prevent plugins and themes from accidentally causing a vulnerability. Reported by Slavco.
  2. A cross-site scripting (XSS) vulnerability was discovered in the oEmbed discovery. Reported by xknown of the WordPress Security Team.
  3. A cross-site scripting (XSS) vulnerability was discovered in the visual editor. Reported by Rodolfo Assis (@brutelogic) of Sucuri Security.
  4. A path traversal vulnerability was discovered in the file unzipping code. Reported by Alex Chapman (noxrnet).
  5. A cross-site scripting (XSS) vulnerability was discovered in the plugin editor. Reported by 陈瑞琦 (Chen Ruiqi).
  6. An open redirect was discovered on the user and term edit screens. Reported by Yasin Soliman (ysx).
  7. A path traversal vulnerability was discovered in the customizer. Reported by Weston Ruter of the WordPress Security Team.
  8. A cross-site scripting (XSS) vulnerability was discovered in template names. Reported by Luka (sikic).
  9. A cross-site scripting (XSS) vulnerability was discovered in the link modal. Reported by Anas Roubi (qasuar).

In addition to the security issues above, WordPress 4.8.2 contains six maintenance fixes to the 4.8 release series.

Let's do some math.

There are 75 million of WordPress websites. Minimally 36 millions (48%) are affected by 10 vulnerabilities and 75 millions of them are affected by host header attack vulnerability.

More details on: